RC51 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi from a new member, I have problems with a 2000 SP1, it bogs down when accelerating.
It had been standing a lot and not used much by the previous owner. Is there any weakness in the fuel system, I am going to take the tank of and make sure it's clean inside, I assume there's a fuel filter in the tank.
Do the fuel pumps have problems with this bike, I suppose it standing long time between rides didn't help the fuel system. It was serviced by a motorcycle shop but they could not find what was causing this hesitation when accelerating, I have an Aprilla rsv factory 2005 and I know they suffer from the fuel filter getting blocked inside the petrol tank. All advice and suggestions would be greatly appreciated.
Many thanks Rich.

Sent from my E5823 using Tapatalk
 

·
Registered
Joined
·
1,628 Posts
yes the fuel pump has a replaceable filter on it.

is the bogging consistent? like you twist on it and it goes nowhere?

does the bike idle normally and ride normally at maintenance throttle, and only bog on accel? there are too many questions to ask and it would help if you described the symptoms more clearly.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi Wibbly, thanks so much for your reply, I am away for 3 to four weeks shortly but I understand that you would need some more information to help me. But I am glad that there is help on the forum. As soon as I return I will put together a more detailed description of the symptoms. It does idle fine, it's only on acceleration. It had a service by the previous owner, I need to go through that paper work aswell. A very special bike I am impressed with its character. Thanks again.

Sent from my E5823 using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I only just acquired bike recently, only had two rides on it one being a test ride . As soon as I return I will take out and put together a more comprehensive picture of what and when it's happening, thanks.

Sent from my E5823 using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Thanks madbuyer, I shall look into that aswell on my return.

Sent from my E5823 using Tapatalk
 

·
Registered
Joined
·
123 Posts
Run a can of sea foam through it.....put it in the gas tank.......
Couldn't hurt. I've excellent results with Berryman's. The smell alone tells you it's STRONG. :surprise: Some cars and bikes don't seem to like the recommended amounts of FI cleaners , my RC being one of them.
 
1 - 8 of 8 Posts
Top