RC51 Forums banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
6,501 Posts
Any fuses blown? Including the FI fuse near the battery?
Was the bike running recently or never since the wreck?
If not after the wreck, what was damaged?
It might help to know what we're dealing with, especially if the wiring harness or switches were damaged.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #5 ·
tipover switch

The fuses are good. It never ran after the wreck. It did roll over and the fuel pump sounded as if it was running after the wreck. As for the damage-the rear rim is smashed,the front fearing and snorkel, and right side road rash.
 

·
Premium Member
Joined
·
6,501 Posts
The MAP sensor is at the front of the snorkel.
The system will show a FI light if it's bad, but will run without it, although not as well.
Now if the wiring harnesses are badly damaged around that area, it could be anything.
 

·
Registered
Joined
·
422 Posts
1 of my mate lost 1 of the screw of the tip over & the thing is slightly run off the position...the bike wont start or dies when u up right it but runs when on side stand.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #9 ·
tipover switch

Thanks to everyone for their help. After carefully looking things over and using a wiring diagram. I seem to have lost the converter unit relay in the wreck. Could this have something to do with it?
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #11 ·
tipover switch

It may not be a relay,but it shows it on the wiring diagram. It is called the the converter unit. It is a plug in with four wires. I also looked it up on a site that showed it and sells it as an OEM item. Their is also one on E-BAY.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top