RC51 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
My Rc is a 2000 and my trip meter is resetting itself for some reason... There doesnt appear to be a short in the gauges area.. I assume that if there were, it would be blinking off and on randomly... there doesnt seem to be any clues as to what might be causing it.. I am stumped.. Please help!!:confused:

Also I have another question regarding the gauges.. When I ride I like to keep them toggled to engine Temp... but every time I shut the bike off, when I go to turn it back on the gauge then is toggled to my overall miles... Is this just how the RC operates or do I have another issue??
 

·
Registered
Joined
·
215 Posts
My bike does the same thing. I don't think my battery is weak, cause the bike cranks fine. What does the PC have to do with it? I have not even tried to look into this issue yet because it kind of bothers me but not enough to get me off my ass. I was going to guess the cluster is suppose to have power with the key off and its missing.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #5
A weak or dying battery causes that condition. Some RC51's fitted with first gen PCII's instead of PCIII's also had that same issue exacerbated.
Battery is brand new.. and the PCIII is on its way as we speak.. SO could it be a loose wire possibly??
 

·
Registered
Joined
·
46 Posts
Discussion Starter #6
My bike does the same thing. I don't think my battery is weak, cause the bike cranks fine. What does the PC have to do with it? I have not even tried to look into this issue yet because it kind of bothers me but not enough to get me off my ass. I was going to guess the cluster is suppose to have power with the key off and its missing.
Same here,, NBike cranks like a champ.. I hadnt thought of the trickle power supply though.. thats worth checking into... could be like a car stereo, and just needs that slight trickle of power to hold your settings.. ?? I guess.
 
1 - 6 of 6 Posts
Top