RC51 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1 (Edited)
So I noticed my downshifts were a little tight (I have Sato Reverse shift pattern so I downshift up and can easily tell).

Yesterday the bike seemed like it didnt want to downshift without multiple attempts, today I cannot downshift into anything below 4th without stopping and jerking up and down with my hand.

It feels like there is no "detent" or spring return on the downshift side of things.

I am guess it is, something dry, a broken spring or something, the bike has 9000 miles and has NOT been abused.

This is my daily driver and I need to fix right away, I have looked at the shift star and suspect maybe my spring is broken or shot or loose, or perhaps the roller bearing is shot (if stock has one)

FYI the bike upshifts fine but has generally felt "clunky" on most shifts.

any ideas? HELP!!!!!

attached is a pic of the evo shift star for reference, not my bike

 

·
Registered
Joined
·
291 Posts
so when you downshift does the lever just stay up? Will it not go into the lower gear? What did you see when you pulled the cover?
 

·
Registered
Joined
·
140 Posts
Discussion Starter #4
Thanks for the resposes guys, the shift linkage is perfect, no binding what so ever, this happened on the way to work (I am at work now), so I have not pulled the cover yet.

When I downshift (with my hand) it just kinda of moves, no real click, no spring effect (if you know what I mean).

Thanks for the links, I searched but came up with nothing.

I think it is the spring too

I will take it apart tonight after work
 
1 - 4 of 4 Posts
Top