RC51 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
So, here's the deal, I was riding home from my buddy's house on the freeway, tried to use the left turn signal, it wouldn't work, as I progressed down the freeway, I could get intermittent response, normally 2-3 flashes and it would stop. High beams work and right turn signal works. Here's the crazy part, I stop my bike to open my garage door, and decide to just try it one more time, this time it worked just fine. So, I think my switch might be starting to go bad, but I'm not sure, just wanting to verify with other people. Oh yeah, she's a 2003 SP2
 

·
Registered
Joined
·
332 Posts
Is the switch "soft" when you move it back and forth? I.e. does the switch feel like it's getting worn on the inside? They typically wear out after a few hundred/thousand switches back and forth. Environment can have something to do with it too...

It is possible to rebuild the components inside, but it involves soldering and finding the replacement parts. Easier to just get a replacement! :)
 

·
Registered
Joined
·
138 Posts
Discussion Starter #4
Thanks, yeah, my suspicion has been confirmed, I need to replace the switch, and I might as well just replace the whole unit.
 

·
Registered
Joined
·
4 Posts
Hey Guys does anyone have an exploded view of the inner part of the left control module. I took it apart and am having a heck of a time putting back together?

I checked the manual and it does not have an inside view of it?
Any help would be appreciated..
 

·
Registered
Joined
·
4 Posts
Thanks for the help your bike looks great! Still can't find a blowout view of The turn signal and hi beam low beam switch I think people just rip the old one out and replace it with a new one?
 
1 - 9 of 9 Posts
Top