RC51 Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Just dumped all the rain water out of my gas tank...ugh. Upon closer inspection of the gas cap, I can see how it got there. I looks like I'm missing a rubber seal or something. You can see (hopefully) the gap between the tank and the gas cap where water could easily make its way into the tank.

I looked for an OEM type part on Bikebandit, but they only show the entire gas cap on the schematic, no separate seal or anything. Was hoping someone could take a look at their bike and let me know if I'm missing a piece there. (It's a 2004) Thanks!
 

Attachments

·
Registered
Joined
·
131 Posts
The "seal" is around the part that flips open. Not around the outside edge. Mine looks just like the pics you posted.
edit: snapped a pic...

 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
The cap seals fine. It's just that gap you see around the outside edge (b/w silver ring and black gas tank) that lets water in.
 

·
Registered
Joined
·
131 Posts
The cap seals fine. It's just that gap you see around the outside edge (b/w silver ring and black gas tank) that lets water in.
Mine looked just like yours. I don't think there's a seal around that part.
I thought you were getting water in the actual "tank".
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
That hole does indeed drain. Well damn...now I don't know how water got there. I usually park it in a storage unit, but the one night I left it outside, it stormed like crazy and the next day wouldn't start. When I drained the tank it must have had several ounces of water in it.

I guess I'll take a closer look when I get the tank repainted. Thanks for pointing that out.
 

·
Registered
Joined
·
149 Posts
My guess is your tank cap DOESN'T SEAL PROPERLY, allowing water to get into the tank. Also, that drain may be crimped or plugged allowing the well to fill with water, capitalizing on a poor sealing cap.


John
 

·
Registered
Joined
·
753 Posts
HAHA I just had this exact same problem, what a bi$ch! Now I did notice that my rubber overflow pipe was blocked with crap for the over flow....! so maybe it was filling up and draining slowly. urgh.. Thanks for this...

Where did you buy a new rubber seal from?
 

·
Premium Member
Joined
·
8,329 Posts
HAHA I just had this exact same problem, what a bi$ch! Now I did notice that my rubber overflow pipe was blocked with crap for the over flow....! so maybe it was filling up and draining slowly. urgh.. Thanks for this...

Where did you buy a new rubber seal from?
That post is a few years old....try www.hondaeasttoledo.com
 

·
Registered
Joined
·
382 Posts
Yeah, make sure that little drain hole is clear and free of debris. If it is clear, there is no way that the water should get to the level that the water would have a chance to back up into the tank, via the rubber seal.

Oh, and IIRC that hose is one of them that runs down the left side fairing. Not 100% sure though. Just make sure it isn't pinched.
 
1 - 10 of 10 Posts
Top