RC51 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
Does anyone have a spare Proton turn signal, my new ones arrived today and one signal is faulty with no running light and very weak flash. Proton just said Oh! that'll be another $80 dollars please.
 

·
Registered
Joined
·
2,186 Posts
Wow, serious? That's terrible.

If paid by CC I'd do a charge back if they don't make it right. Call your CC company and say you received defective product.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #4
I'm surprised you didn't go with Watsen 8igstu? Considering their based out of Alberta...
I didn't know they existed, their site says they're not taking orders at the moment.:(
 

·
Registered
Joined
·
96 Posts
Discussion Starter #7
I think they were implying I wired it wrong, This is the wiring I used:
Front right signal:
Green = Ground / to their Black
Light Blue/White = Running light / to their Red
Light Blue = Signal / to their Orange, the yellow is the strobe option
(You can combine orange and yellow for some funky light show, I didn't try it)

Front left signal:
Green = Ground / to their Black
Orange/White = Running Light / to their Red
Orange = Signal / to their Orange,

I'll wait a couple of days to see how it pans out or if anyone has one of a crashed bike they want to sell, I'll go fit my new front/rear brake lines while I'm waiting
 

·
Registered
Joined
·
753 Posts
Just wondering, have you tried switching them round and putting it on the other side? Just to rule everything out that it's the proton? I'm sure it is but it'll probs only take 2 secs. But I'd be kicking up hell!

Good luck with it and sorry to hear about the hassle.


Sent from Motorcycle.com Free App
 
1 - 8 of 8 Posts
Top